Test Fabio

Incident Report for Primeo Energie Netzstatus

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 16:46 CEST

Investigating

We are currently investigating this issue.
Posted Apr 22, 2025 - 16:46 CEST